Перейти к содержимому

Тестирование веб-приложений 2.0
онлайн, начало 29 мая
Автоматизация функционального тестирования
онлайн, начало 29 мая
Первый Онлайн ИНститут Тестировщиков
онлайн, начало 21 июня
Школа тест-менеджеров v. 2.0
онлайн, начало 27 мая
Фотография

TestLink


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 28

#1 natvd

natvd

    Новый участник

  • Members
  • Pip
  • 4 сообщений

Отправлено 27 октября 2005 - 15:52

Добрый день.
Подскажите, пожалуйста, кто работал с системой управления и выполнения тестов TestLink 1.5.1:"Как при создании Test Cases настроить русский язык?".
Сейчас при создании в полях можно использовать только английский язык, русский отображается в виде знаков вопросов при сохранении.
Может необходимо добавить какой-то шрифт?

Спасибо за помощь.
  • 0

#2 Clauster

Clauster

    Гуру

  • Members
  • PipPipPipPipPipPip
  • 1 913 сообщений
  • ФИО:Худобородов Валерий
  • Город:Espoo

Отправлено 27 октября 2005 - 16:02

Скорее всего там проблема с кодировками в MySQL. Если у меня руки доберутся отпишу, как сделать. Или сами разберитесь, если поняли о чём я.
  • 0

#3 Clauster

Clauster

    Гуру

  • Members
  • PipPipPipPipPipPip
  • 1 913 сообщений
  • ФИО:Худобородов Валерий
  • Город:Espoo

Отправлено 27 октября 2005 - 17:02

у вас MySQL какой версии?
  • 0

#4 Clauster

Clauster

    Гуру

  • Members
  • PipPipPipPipPipPip
  • 1 913 сообщений
  • ФИО:Худобородов Валерий
  • Город:Espoo

Отправлено 27 октября 2005 - 17:16

В общем, у меня так:
1. MySQL 4.1, default-character-set=latin1 (это строчка из my.ini)
2. Кодировка БД TestLink - utf8_general_ci
3. В файлике ..\testlink\config.inc.php строка define('DB_SUPPORTS_UTF8', TRUE); По умолчанию там FALSE.
И всё замечательно и по-русски.
  • 0

#5 pnV

pnV

    Новый участник

  • Members
  • Pip
  • 5 сообщений
  • Город:г. Москва

Отправлено 28 октября 2005 - 08:08

а может просто в ..\testlink\config.inc.php написать pageCharset windows-1251
  • 0

#6 natvd

natvd

    Новый участник

  • Members
  • Pip
  • 4 сообщений

Отправлено 28 октября 2005 - 09:15

Спасибо, pnV, ваш вариант проверила, но лучше не стало :( .
Сейчас работаю над способом решения проблемы от Clauster, надеюсь, что всё получится :)
  • 0

#7 pnV

pnV

    Новый участник

  • Members
  • Pip
  • 5 сообщений
  • Город:г. Москва

Отправлено 28 октября 2005 - 11:04

Спасибо, pnV, ваш вариант проверила, но лучше не стало :( .
Сейчас работаю над способом решения проблемы от Clauster, надеюсь, что всё получится :)

Просмотр сообщения

Остальные параметры у меня отличаются от указанных выше коллегой:
MySQL 4.1, default-character-set=cp1251
Кодировка БД TestLink - cp1251_general_ci
В файлике ..\testlink\config.inc.php строка define('DB_SUPPORTS_UTF8', FALSE);
  • 0

#8 Clauster

Clauster

    Гуру

  • Members
  • PipPipPipPipPipPip
  • 1 913 сообщений
  • ФИО:Худобородов Валерий
  • Город:Espoo

Отправлено 28 октября 2005 - 11:14

В общем, в MySQL, начиная с версии 4.1, по идее, не важно какая кодировка, там ведь можно у каждой базы свою кодировку указывать.
  • 0

#9 Clauster

Clauster

    Гуру

  • Members
  • PipPipPipPipPipPip
  • 1 913 сообщений
  • ФИО:Худобородов Валерий
  • Город:Espoo

Отправлено 28 октября 2005 - 11:19

Короче, если вы используете автом-ю инсталляцию TestLink, попробуйте сначала поставить у MySQL кодировку utf8, проинсталлировать TestLink, потом поставьте обратно latin1 и config.inc.php соответственно отредактируйте. Не забывайте переталкивать MySQL при смене кодировки.
  • 0

#10 natvd

natvd

    Новый участник

  • Members
  • Pip
  • 4 сообщений

Отправлено 31 октября 2005 - 09:20

Спасибо, Clauster, за помощь.
Получилось настроить кодировку.
  • 0

#11 galogenIt

galogenIt

    Постоянный участник

  • Members
  • PipPipPip
  • 192 сообщений
  • ФИО:Эдуард

Отправлено 11 февраля 2009 - 19:06

Хочу реанимировать тему на предмет вопросов по использованию Testlink.

Не скажу, что перебирал множество вариантов. Из доступных совершенно не много, да и времени , если честно нет совсем. Нужен достаточно удобный более или менее нажедный и общедоступный инструмент.

В качестве кандидатов рассматривались: Excel, RaQuest, TestLink и Devprom (devprom.net).

Решил пока остановиться на testlink. Выбрал testlink 1.8 RC4 последний в общим самый. Тестируется пока на denwer. И вот ряд вопросов.

1. Как мне перенести базу с denwer на общедоступный сайт? Сделать backup и восстановить его уже на хостинге?

2. Список тестовых наборов и случаев отображается слева во фреймовом контейнере. Но вот что мне не нравится, контейнер ограничен до середины страницы и я бы с удовольствием его раздвинул, только вот в каком файле править? Может кто подскажет

3. В testlink используется широко известный FCKeditor. И вот что мне в нем не нравится. Попытка закачать на сервер (в данном случае работаем локально на денвере) картинку или файл приводит к ошибке во весь экран. Вообще работает эта фича коряво и отвратительно.

Кто сталкивался, как боролся, что посоветует?

Благодарю
  • 0
С уважением, Эдуард!

#12 Avg00r

Avg00r

    Новый участник

  • Members
  • Pip
  • 42 сообщений
  • ФИО:Вадим Янгунаев
  • Город:Самара


Отправлено 13 апреля 2009 - 15:05

В качестве кандидатов рассматривались: Excel, RaQuest, TestLink и Devprom (devprom.net).Решил пока остановиться на testlink. Выбрал testlink 1.8 RC4 последний в общим самый.

А чем не устроили RaQuest или Devprom?

1. Как мне перенести базу с denwer на общедоступный сайт? Сделать backup и восстановить его уже на хостинге?

А именно так сделать получается?

2. Список тестовых наборов и случаев отображается слева во фреймовом контейнере. Но вот что мне не нравится, контейнер ограничен до середины страницы и я бы с удовольствием его раздвинул, только вот в каком файле править? Может кто подскажет

Граница двигается в любую сторону до любого состояния. У меня правда версия 1.7.5 (в IE и Chrome)

3. В testlink используется широко известный FCKeditor. И вот что мне в нем не нравится. Попытка закачать на сервер (в данном случае работаем локально на денвере) картинку или файл приводит к ошибке во весь экран. Вообще работает эта фича коряво и отвратительно.

Проделайте шаги, описанные здесь (второй пост). У меня все сработало :)
  • 0

468x60.jpg


#13 igor.lyubin

igor.lyubin

    Новый участник

  • Members
  • Pip
  • 24 сообщений
  • ФИО:igor lyubin
  • Город:Moscow


Отправлено 12 мая 2009 - 14:45

Добрый день.
Подскажите, пожалуйста, кто работал с системой управления и выполнения тестов TestLink 1.5.1:"Как при создании Test Cases настроить русский язык?".
Сейчас при создании в полях можно использовать только английский язык, русский отображается в виде знаков вопросов при сохранении.
Может необходимо добавить какой-то шрифт?

Спасибо за помощь.


Если TestLink 1.8.2, MySQL 5, то все просто!
В файлике config.inc.php пропишите: $tlCfg->charset = 'Windows-1251';.
  • 0

#14 ALino

ALino

    Новый участник

  • Members
  • Pip
  • 4 сообщений
  • ФИО:Клочкова Анастасия Николаевна
  • Город:Санкт-Петербург


Отправлено 06 августа 2009 - 23:38

Здравствуйте!

Написала в файле config.inc.php $tlCfg->charset = 'Windows-1251'; и в тест-кейсах русский язык появился. Но в дереве у меня русский шрифт по-прежнему не отображается. Подскажите, пожалуйста, как с этим бороться.

Спасибо за помощь
  • 0

#15 Tuchka_84

Tuchka_84

    Активный участник

  • Members
  • PipPip
  • 105 сообщений
  • ФИО:Маша

Отправлено 26 апреля 2010 - 09:05

Здравствуйте,
Хочу еще раз поднять данный вопрос с корректной настройкой русского языка.
Я поставила TestLink 1.8.5. База автоматически установилась UTF-8. В config.inc.php прописано $tlCfg->charset = 'UTF-8';
Проблема возникла с Отчетами в виде диаграмм . В отчетах все надписи к диаграммам в виде аброкадабры ( квадратиками).
Такая же ботва у меня была с русским шрифтом в отчетах багзилы, но в ней я поправила CGI и все заработало.
Похоже здесь что-то аналогичное надо сделать, но где копать не знаю.
Если кто сталкивался с этим и знает , как проблему решить напишите пожалуйста.
Заранее спасибо.
  • 0

#16 Slip

Slip

    Новый участник

  • Members
  • Pip
  • 14 сообщений
  • ФИО:Andrey

Отправлено 12 октября 2010 - 12:32

Здравствуйте!

Написала в файле config.inc.php $tlCfg->charset = 'Windows-1251'; и в тест-кейсах русский язык появился. Но в дереве у меня русский шрифт по-прежнему не отображается. Подскажите, пожалуйста, как с этим бороться.

Спасибо за помощь


аналогичная проблема, может кто подскажет решение? версия тестлинка последняя

вопрос решился, виноват Апач был ;)

Сообщение отредактировал Slip: 12 октября 2010 - 12:52

  • 0

#17 VicProg

VicProg

    Новый участник

  • Members
  • Pip
  • 15 сообщений
  • ФИО:Виктор
  • Город:г. Киев


Отправлено 21 октября 2010 - 11:26


Здравствуйте!

Написала в файле config.inc.php $tlCfg->charset = 'Windows-1251'; и в тест-кейсах русский язык появился. Но в дереве у меня русский шрифт по-прежнему не отображается. Подскажите, пожалуйста, как с этим бороться.

Спасибо за помощь


аналогичная проблема, может кто подскажет решение? версия тестлинка последняя

вопрос решился, виноват Апач был ;)


А Вы не подскажете в чем именно был виноват apache, т.к. у меня та же проблема что была у Вас, посмотрел в apache в файл httpd там
у меня стоит значение:
AddDefaultCharset windows-1251
в файле config.inc.php TestLink-а:
$tlCfg->charset = 'windows-1251'
$tlCfg->default_language = 'ru_RU';
вроде все синхронно, но несмотря на это в дереве русский шрифт не отображается

Спасибо
  • 0

#18 VicProg

VicProg

    Новый участник

  • Members
  • Pip
  • 15 сообщений
  • ФИО:Виктор
  • Город:г. Киев


Отправлено 20 января 2011 - 09:01



Здравствуйте!

Написала в файле config.inc.php $tlCfg->charset = 'Windows-1251'; и в тест-кейсах русский язык появился. Но в дереве у меня русский шрифт по-прежнему не отображается. Подскажите, пожалуйста, как с этим бороться.

Спасибо за помощь


аналогичная проблема, может кто подскажет решение? версия тестлинка последняя

вопрос решился, виноват Апач был ;)


А Вы не подскажете в чем именно был виноват apache, т.к. у меня та же проблема что была у Вас, посмотрел в apache в файл httpd там
у меня стоит значение:
AddDefaultCharset windows-1251
в файле config.inc.php TestLink-а:
$tlCfg->charset = 'windows-1251'
$tlCfg->default_language = 'ru_RU';
вроде все синхронно, но несмотря на это в дереве русский шрифт не отображается

Спасибо



Никто не подскажет в чем проблема?
Поковырял все что мог: БД и файлы TestLink-а, Apache, но русские шрифты в дереве наименовании тест-кейсов не отображаются.
Версия TestLink 1.9

Прикрепленные файлы

  • Прикрепленный файл  s200111-1.jpg   27,74К   72 Количество загрузок:

  • 0

#19 Vremya

Vremya

    Новый участник

  • Members
  • Pip
  • 1 сообщений
  • ФИО:Вебер Денис Викторович


Отправлено 08 октября 2012 - 11:09

Привет всем, вот у меня такая проблема:
В тестлинке 1.9.1 хочу распечатать список требований в котором существует:
1. Название требования (русские буквы)
2. Описание требования (русские буквы)
3. Название кейса слинкованного с этим требованием (русские буквы)
Выгрузка производится в html или .doc
Все кроме названия кейса отображается корректно. А вот название кейса выглядит так: Ð�бÑ�ий мониÑ�оÑ�инг
Может подскажите как это излечить кто сталкивался?
  • 0

#20 Olits

Olits

    Новый участник

  • Members
  • Pip
  • 1 сообщений
  • ФИО:Olits

Отправлено 29 ноября 2013 - 08:30

Добрый день. Есть ли у кого мануал по работе с Testlink 1.9 на русском? Буду очень благодарен.
  • 0


Тестирование REST API
онлайн
Программирование на Java для тестировщиков
онлайн
SQL для тестировщиков
онлайн
Программирование на С# для тестировщиков
онлайн



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных

Яндекс.Метрика
Реклама на портале