Перейти к содержимому

Аудит и оптимизация QA-процессов
онлайн, начало 4 декабря
Практикум по тест-дизайну 2.0
онлайн, начало 4 декабря
Логи как инструмент тестировщика
онлайн, начало 30 ноября
Тестирование REST API
онлайн, начало 30 ноября
Фотография

Вопрос к профи по Selenium Grid


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 2

#1 PunkLiner

PunkLiner

    Новый участник

  • Members
  • Pip
  • 73 сообщений


Отправлено 23 апреля 2013 - 11:55

Здравствуйте уважаемые!

Собственно ситуация следующая:
Имеются 18 классов с тестами. Файлик TestNG.xml выглядит приблизительно следующим образом:

<!DOCTYPE suite SYSTEM "http://testng.org/testng-1.0.dtd" >
<suite name="All-Parallel" parallel="classes" thread-count="4">

<parameter name="thread-count" value="4"/>
<listeners>

<listener class-name="utils.Listener"/>
</listeners>
<test name="test">
<classes>
<class name="Class1"/>
<class name="Class2"/>
<class name="Class3"/>
..........
..........
<class name="Class18"/>
</classes>


</test>
</suite>

Использую Selenium Grid. Запускаю 4 узла на разных VM. Понеслось...На всех четырех нодах начали выполняться тесты. Через какое то время, 3 из них прекращают свою работу. Ноды, вместо выполнения теста пишут INFO - Done: /status (работают, но ничего не делают) В консоли хаба значки браузера подсвечены, так, будто узлы заняты (будто на них что то выполняется). Хотя по факту выполняются только на одном. Потом, еще через какое то время тот нод, единственный, на котором выполнялись тесты также останавливается, и тесты начинают выполняться уже на другом ноде, который "стоял"..Что за чепуха? Почему сначала работали все 4, а потом только 1, и то попеременно?

Спасибо!
  • 0

#2 adzynia

adzynia

    Постоянный участник

  • Members
  • PipPipPip
  • 210 сообщений
  • ФИО:Дзыня Андрей


Отправлено 02 июня 2013 - 17:23

Может быть проблема в создании объекта WebDriver. Поэкспериментируйте с разными Before и After аннотациями, и не забудьте проверить с ключем alwaysRun = true
  • 0

#3 sawoy

sawoy

    Новый участник

  • Members
  • Pip
  • 51 сообщений
  • ФИО:Alex Savchuk

Отправлено 03 июня 2013 - 08:22

Привет!

Использую Selenium Grid. Запускаю 4 узла на разных VM. Понеслось...На всех четырех нодах начали выполняться тесты. Через какое то время, 3 из них прекращают свою работу. Ноды, вместо выполнения теста пишут INFO - Done: /status (работают, но ничего не делают) В консоли хаба значки браузера подсвечены, так, будто узлы заняты (будто на них что то выполняется). Хотя по факту выполняются только на одном. Потом, еще через какое то время тот нод, единственный, на котором выполнялись тесты также останавливается, и тесты начинают выполняться уже на другом ноде, который "стоял"..Что за чепуха? Почему сначала работали все 4, а потом только 1, и то попеременно?


для меня это выглядит так:
1. тесты нормально начинают выполняться на всех нодах
2. на 3 нодах по какой то причине отваливается браузер или что-то еще, но сессия некоторое время не теряется (хаб ждет таймаута)
3. на последней ноде тоже отваливается браузер или что-то еще, снова ждется таймаут. При это другие ноды уже "освободились" и хаб перенаправляет исполнение на них

так что:

1. нужно понять почему падает исполнение теста - смотрите логи java ноды (-debug или адже так может быть видно)
2. для более ясного понимания желательно иметь полный набор информации - логи, тесты, конфигурация грида


P.S.: "В консоли хаба значки браузера подсвечены" - и что показывается при наведении мыши на значки браузеров - какая команда выполнялась последней ?
  • 0


Selenium 2.0: стартовый уровень
онлайн
Программирование на Java для тестировщиков
онлайн
Автоматизация функционального тестирования
онлайн
Selenium WebDriver: полное руководство
онлайн



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных

Яндекс.Метрика
Реклама на портале