Перейти к содержимому

Тестирование без требований
онлайн, начало 25 января
Тестирование безопасности
онлайн, начало 25 января
Школа Тест-Аналитика
онлайн, начало 27 января
Тестирование производительности: JMeter 5
онлайн, начало 22 января
Фотография

Установка Selenium RC


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 49

#41 panamama

panamama

    Новый участник

  • Members
  • Pip
  • 13 сообщений
  • ФИО:Махник Максим
  • Город:Киев

Отправлено 30 января 2014 - 12:00

Master_lomaster, убрал плагин Сервера с Нетбимса-запустил сервер в ручную-работает, думаю еще связку Еклипс-вебдрайвер погонять. Очень подкупает простота настройки среды


  • 0

#42 vuchenka

vuchenka

    Постоянный участник

  • Members
  • PipPipPip
  • 174 сообщений
  • ФИО:Ирина
  • Город:Минск

Отправлено 31 января 2014 - 13:13

Master_lomaster, убрал плагин Сервера с Нетбимса-запустил сервер в ручную-работает, думаю еще связку Еклипс-вебдрайвер погонять. Очень подкупает простота настройки среды

может сможете мне помочь, у меня тесты не запускаются не через Эклипс, и не через NB, пишу на PHP

стоит PHPEclipce

при запуске в NB пишет, что файл не найден. Что за файл должен быть? что в нем?

установлен апач 2, денвер, ява, пхпюнит, пхпшторм.

 

 

вот код:

<?php
class Example extends PHPUnit_Extensions_SeleniumTestCase
{
  protected function setUp()
  {
    $this->setBrowser("*chrome");
    $this->setBrowserUrl("http://testing.ееее.by/");
  }

  public function testMyTestCase()
  {
    $this->open("/kis/web/");
    $this->type("id=login-name", "дзж");
    $this->type("id=login-password", "льбжд");
    $this->click("id=login-rememberme");
    $this->click("name=submit");
    $this->waitForPageToLoad("30000");
    $this->click("link=Бас");
    $this->waitForPageToLoad("30000");
    $this->click("link=Аттестация");
    $this->waitForPageToLoad("30000");
    $this->click("link=Редактировать");
    $this->waitForPageToLoad("30000");
    $this->click("link=Выход");
    $this->waitForPageToLoad("30000");
  }
}
?>

 

 

в NB запускается тест до этого места

 $this->open("/kis/web/");
    $this->type("id=login-name", "admin");
    $this->type("id=login-password", "123456");
    $this->click("id=login-rememberme");
    $this->click("name=submit");
    $this->waitForPageToLoad("30000");
    $this->click("link=Бас);
    $this->waitForPageToLoad("30000");
    $this->click("link=Аттестация");
    $this->waitForPageToLoad("30000");
    $this->click("link=Редактировать");
    $this->waitForPageToLoad("30000");
    $this->click("link=Выход");
    $this->waitForPageToLoad("30000");
  }
}
 


  • 0

"Не сломал - значит, не старался!"


#43 BabyRoot

BabyRoot

    Специалист

  • Members
  • PipPipPipPipPip
  • 803 сообщений


Отправлено 31 января 2014 - 13:27

Добавьте ещё что он пишет-то. ))


  • 0

#44 vuchenka

vuchenka

    Постоянный участник

  • Members
  • PipPipPip
  • 174 сообщений
  • ФИО:Ирина
  • Город:Минск

Отправлено 20 февраля 2014 - 07:26

Добавьте ещё что он пишет-то. ))

 

в NB я уже не могу наткнутся на сообщение, что файл не найден.

сейчас при запуске он в браузере открывает главную страницу сайта, и на 10 строчке кода останавливается.

Может как-то связано с файлом phpunit-skelgen. У меня к нему не прописан путь, т.к у меня этого файла нет.

Может еще какие-то манипуляции делать надо? я просто скопировала с силениума код, вставила в NB и запускаю.

И что за "укажите местоположение соответствующих исходных файлов"? это я тут вычитала https://netbeans.org...t-setup_ru.html

 

 

а в Эклипс выдает сообщение об ошибке.

 

Извините, за столь, глупые вопросы, но я первый раз сталкиваюсь с автоматизацией.

Прикрепленные файлы

  • Прикрепленный файл  1.PNG   144,24К   1 Количество загрузок:

  • 0

"Не сломал - значит, не старался!"


#45 Master_lomaster

Master_lomaster

    Новый участник

  • Members
  • Pip
  • 50 сообщений

Отправлено 20 февраля 2014 - 09:54

 

Добавьте ещё что он пишет-то. ))

 

в NB я уже не могу наткнутся на сообщение, что файл не найден.

сейчас при запуске он в браузере открывает главную страницу сайта, и на 10 строчке кода останавливается.

Может как-то связано с файлом phpunit-skelgen. У меня к нему не прописан путь, т.к у меня этого файла нет.

Может еще какие-то манипуляции делать надо? я просто скопировала с силениума код, вставила в NB и запускаю.

И что за "укажите местоположение соответствующих исходных файлов"? это я тут вычитала https://netbeans.org...t-setup_ru.html

 

 

а в Эклипс выдает сообщение об ошибке.

 

Извините, за столь, глупые вопросы, но я первый раз сталкиваюсь с автоматизацией.

 

Точка с запятой же не стоит в строчке №9.  Вы бы хоть смотрели, на какие ошибки указывает Netbeans...


  • 0

#46 Master_lomaster

Master_lomaster

    Новый участник

  • Members
  • Pip
  • 50 сообщений

Отправлено 20 февраля 2014 - 09:59

 

 

Добавьте ещё что он пишет-то. ))

 

в NB я уже не могу наткнутся на сообщение, что файл не найден.

сейчас при запуске он в браузере открывает главную страницу сайта, и на 10 строчке кода останавливается.

Может как-то связано с файлом phpunit-skelgen. У меня к нему не прописан путь, т.к у меня этого файла нет.

Может еще какие-то манипуляции делать надо? я просто скопировала с силениума код, вставила в NB и запускаю.

И что за "укажите местоположение соответствующих исходных файлов"? это я тут вычитала https://netbeans.org...t-setup_ru.html

 

 

а в Эклипс выдает сообщение об ошибке.

 

Извините, за столь, глупые вопросы, но я первый раз сталкиваюсь с автоматизацией.

 

Точка с запятой же не стоит в строчке №9.  Вы бы хоть смотрели, на какие ошибки указывает Netbeans...

 

И, кстати, в setUp не должно быть, собственно, теста. Там только настройки перед его выполнением (setBrowser, setBrowserUrl и т.д.). Сам тест должен быть в функции, название которой начинает с "test."

Мануал phpunit.de, глава 17 вам в помощь :) Настоятельно рекомендую прочитать хотя бы ее, иначе вряд ли что-то получится.


  • 0

#47 vuchenka

vuchenka

    Постоянный участник

  • Members
  • PipPipPip
  • 174 сообщений
  • ФИО:Ирина
  • Город:Минск

Отправлено 20 февраля 2014 - 11:38

 

 

 

Добавьте ещё что он пишет-то. ))

 

в NB я уже не могу наткнутся на сообщение, что файл не найден.

сейчас при запуске он в браузере открывает главную страницу сайта, и на 10 строчке кода останавливается.

Может как-то связано с файлом phpunit-skelgen. У меня к нему не прописан путь, т.к у меня этого файла нет.

Может еще какие-то манипуляции делать надо? я просто скопировала с силениума код, вставила в NB и запускаю.

И что за "укажите местоположение соответствующих исходных файлов"? это я тут вычитала https://netbeans.org...t-setup_ru.html

 

 

а в Эклипс выдает сообщение об ошибке.

 

Извините, за столь, глупые вопросы, но я первый раз сталкиваюсь с автоматизацией.

 

Точка с запятой же не стоит в строчке №9.  Вы бы хоть смотрели, на какие ошибки указывает Netbeans...

 

И, кстати, в setUp не должно быть, собственно, теста. Там только настройки перед его выполнением (setBrowser, setBrowserUrl и т.д.). Сам тест должен быть в функции, название которой начинает с "test."

Мануал phpunit.de, глава 17 вам в помощь :) Настоятельно рекомендую прочитать хотя бы ее, иначе вряд ли что-то получится.

 

спасибо большое, почитаю, но точка с запятой стоит, но почему-то на скриншоте нет, видно перестаралась с инструментом "ластик"


  • 0

"Не сломал - значит, не старался!"


#48 Master_lomaster

Master_lomaster

    Новый участник

  • Members
  • Pip
  • 50 сообщений

Отправлено 20 февраля 2014 - 12:01

 

 

 

 

Добавьте ещё что он пишет-то. ))

 

в NB я уже не могу наткнутся на сообщение, что файл не найден.

сейчас при запуске он в браузере открывает главную страницу сайта, и на 10 строчке кода останавливается.

Может как-то связано с файлом phpunit-skelgen. У меня к нему не прописан путь, т.к у меня этого файла нет.

Может еще какие-то манипуляции делать надо? я просто скопировала с силениума код, вставила в NB и запускаю.

И что за "укажите местоположение соответствующих исходных файлов"? это я тут вычитала https://netbeans.org...t-setup_ru.html

 

 

а в Эклипс выдает сообщение об ошибке.

 

Извините, за столь, глупые вопросы, но я первый раз сталкиваюсь с автоматизацией.

 

Точка с запятой же не стоит в строчке №9.  Вы бы хоть смотрели, на какие ошибки указывает Netbeans...

 

И, кстати, в setUp не должно быть, собственно, теста. Там только настройки перед его выполнением (setBrowser, setBrowserUrl и т.д.). Сам тест должен быть в функции, название которой начинает с "test."

Мануал phpunit.de, глава 17 вам в помощь :) Настоятельно рекомендую прочитать хотя бы ее, иначе вряд ли что-то получится.

 

спасибо большое, почитаю, но точка с запятой стоит, но почему-то на скриншоте нет, видно перестаралась с инструментом "ластик"

 

Странно... Netbeans показывает какую-то синтаксическую ошибку php. Вот код, который вы прилагали выше - корректный. Может, все-таки случайно что-то стерли или добавили в конце предыдущей строки.


  • 0

#49 vuchenka

vuchenka

    Постоянный участник

  • Members
  • PipPipPip
  • 174 сообщений
  • ФИО:Ирина
  • Город:Минск

Отправлено 20 февраля 2014 - 12:29

 

 

 

 

 

Добавьте ещё что он пишет-то. ))

 

в NB я уже не могу наткнутся на сообщение, что файл не найден.

сейчас при запуске он в браузере открывает главную страницу сайта, и на 10 строчке кода останавливается.

Может как-то связано с файлом phpunit-skelgen. У меня к нему не прописан путь, т.к у меня этого файла нет.

Может еще какие-то манипуляции делать надо? я просто скопировала с силениума код, вставила в NB и запускаю.

И что за "укажите местоположение соответствующих исходных файлов"? это я тут вычитала https://netbeans.org...t-setup_ru.html

 

 

а в Эклипс выдает сообщение об ошибке.

 

Извините, за столь, глупые вопросы, но я первый раз сталкиваюсь с автоматизацией.

 

Точка с запятой же не стоит в строчке №9.  Вы бы хоть смотрели, на какие ошибки указывает Netbeans...

 

И, кстати, в setUp не должно быть, собственно, теста. Там только настройки перед его выполнением (setBrowser, setBrowserUrl и т.д.). Сам тест должен быть в функции, название которой начинает с "test."

Мануал phpunit.de, глава 17 вам в помощь :) Настоятельно рекомендую прочитать хотя бы ее, иначе вряд ли что-то получится.

 

спасибо большое, почитаю, но точка с запятой стоит, но почему-то на скриншоте нет, видно перестаралась с инструментом "ластик"

 

Странно... Netbeans показывает какую-то синтаксическую ошибку php. Вот код, который вы прилагали выше - корректный. Может, все-таки случайно что-то стерли или добавили в конце предыдущей строки.

 

да вроде бы все знаки стоят(((((


  • 0

"Не сломал - значит, не старался!"


#50 Master_lomaster

Master_lomaster

    Новый участник

  • Members
  • Pip
  • 50 сообщений

Отправлено 20 февраля 2014 - 12:49

 

 

 

 

 

 

Добавьте ещё что он пишет-то. ))

 

в NB я уже не могу наткнутся на сообщение, что файл не найден.

сейчас при запуске он в браузере открывает главную страницу сайта, и на 10 строчке кода останавливается.

Может как-то связано с файлом phpunit-skelgen. У меня к нему не прописан путь, т.к у меня этого файла нет.

Может еще какие-то манипуляции делать надо? я просто скопировала с силениума код, вставила в NB и запускаю.

И что за "укажите местоположение соответствующих исходных файлов"? это я тут вычитала https://netbeans.org...t-setup_ru.html

 

 

а в Эклипс выдает сообщение об ошибке.

 

Извините, за столь, глупые вопросы, но я первый раз сталкиваюсь с автоматизацией.

 

Точка с запятой же не стоит в строчке №9.  Вы бы хоть смотрели, на какие ошибки указывает Netbeans...

 

И, кстати, в setUp не должно быть, собственно, теста. Там только настройки перед его выполнением (setBrowser, setBrowserUrl и т.д.). Сам тест должен быть в функции, название которой начинает с "test."

Мануал phpunit.de, глава 17 вам в помощь :) Настоятельно рекомендую прочитать хотя бы ее, иначе вряд ли что-то получится.

 

спасибо большое, почитаю, но точка с запятой стоит, но почему-то на скриншоте нет, видно перестаралась с инструментом "ластик"

 

Странно... Netbeans показывает какую-то синтаксическую ошибку php. Вот код, который вы прилагали выше - корректный. Может, все-таки случайно что-то стерли или добавили в конце предыдущей строки.

 

да вроде бы все знаки стоят(((((

 

Уже лучше) Что теперь не работает?


  • 0


Selenium 2.0: стартовый уровень
онлайн
Программирование на Java для тестировщиков
онлайн
Автоматизация функционального тестирования
онлайн
Selenium WebDriver: полное руководство
онлайн



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных

Яндекс.Метрика
Реклама на портале