Перейти к содержимому

Тестирование мобильных приложений
онлайн, начало 6 августа
Тестирование безопасности
онлайн, начало 6 августа
Автоматизация функционального тестирования
онлайн, начало 7 августа
Тестирование веб-приложений 2.0
онлайн, начало 7 августа
Фотография

Run-Time Viewer не показывает стрнаницы приложения


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 2

#1 Stasde

Stasde

    Новый участник

  • Members
  • Pip
  • 71 сообщений

Отправлено 18 апреля 2008 - 09:31

Всем привет!

Прооблема такая - при запуске скрипта в VUGen, RTV не отображает страницы тестируемого приложения.
Скрипт в VUGen при этом выполняется.

-Недавно пареставлена Winodows XP, и LoadRunner установлен на чистую систему.
-LoadRunner 9.0.0.0, build 2889
-IE 6.0.2900.2180
-Все опции в RTV включены.

Выполнил Repair of Load Runner - не помогло.
Перезагрузка компьютера - не помогло.

Кто-нибудь знает, как решить задачку?
Спасибо.
  • 0

#2 mangazey

mangazey

    Активный участник

  • Members
  • PipPip
  • 75 сообщений

Отправлено 18 апреля 2008 - 10:04

Кто-нибудь знает, как решить задачку?


Прежде чем решать задачу, надо убедиться что решение есть. // Эйлер


В том-то и фишка, что *нигде? не утверждается, что Run-Time Viewer *должен* корректно отображать содержимое страницы.
Более того, это ведь даже и не браузер! Просто вспомогательная тулза для помощи в разработке и отладке скрипта.
Рекомендю ознакомится с What are the limitations of the Run-Time Viewer

Если кратко - то RTV в некоторых случаях может некорректно отображать страницу или вовсе ее не отображать. И это не будет являться признаком того, что проблема в самом приложении.
Так что перестановка лоадранера ничего не исправит, т.к. исправлять вообщем-то и нечего. Всё работает корректно - так как и должно работать.

Если необходимо проверять содержимое страницы, можно просматривать ответы (=страницы), полученные от сервера, в tree-view mode.
Либо в самом скрипте можно проводить поиск внутри самой страницы (web_find)
  • 0

#3 Stasde

Stasde

    Новый участник

  • Members
  • Pip
  • 71 сообщений

Отправлено 18 апреля 2008 - 11:01

Спасибо за помощь.

Дело в том что, если запускать тот же скрипт на другой машине, то никаких проблем.
Думаю, что-то не так на моей машине.

Спасибо за ссылку - поищу RTV limitations там.
  • 0


Тестирование производительности (JMeter)
онлайн
Тестирование удобства использования
онлайн
Тестирование REST API
онлайн
Тестирование веб-приложений 2.0
онлайн



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных

Яндекс.Метрика
Реклама на портале