Перейти к содержимому

Программирование на Python для тестировщиков
онлайн, начало 17августа
SQL для тестировщиков
онлайн, начало 20 августа
Программирование на C# для тестировщиков
онлайн, начало 24 августа
Тестирование производительности (JMeter)
онлайн, начало 24 августа
Фотография

Ошибка в eclipse "General error during semantic analysis"

eclipse groovy spock

  • Авторизуйтесь для ответа в теме
Сообщений в теме: 2

#1 Seys_isv

Seys_isv

    Новый участник

  • Members
  • Pip
  • 3 сообщений
  • ФИО:Иванов Станислав

Отправлено 01 Август 2018 - 13:13

Ситуация: устраиваюсь на работу, получил тестовое задание. Что в задании делать понимаю, а как начать запускать тесты - нет. Мне передали тесты, написанные на groovy. Пытаюсь запустить их в eclipse и ловлю такую ошибку:

 
General error during semantic analysis: Transform org.spockframework.compiler.SpockTransform cannot be run

org.codehaus.groovy.GroovyException: Transform org.spockframework.compiler.SpockTransform cannot be run
at org.codehaus.groovy.transform.ASTTransformationVisitor$3.call(ASTTransformationVisitor.java:466)
at org.codehaus.groovy.control.CompilationUnit.applyToSourceUnits(CompilationUnit.java:977)
at org.codehaus.groovy.control.CompilationUnit.doPhaseOperation(CompilationUnit.java:639)
at org.codehaus.groovy.control.CompilationUnit.processPhaseOperations(CompilationUnit.java:615)
at org.codehaus.groovy.control.CompilationUnit.compile(CompilationUnit.java:592)
at org.codehaus.jdt.groovy.internal.compiler.ast.GroovyCompilationUnitDeclaration.processToPhase(GroovyCompilationUnitDeclaration.java:204)

Кто-нибудь может объяснить в чем причина этой ошибки? Мой pom.xml:

 
<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
    <modelVersion>4.0.0</modelVersion>


  <groupId>test</groupId>
  <artifactId>translate</artifactId>
  <version>0.0.1-SNAPSHOT</version>
  <packaging>jar</packaging>
  
  <name>translate</name>
  
  <dependencies>
    <dependency>
      <groupId>org.codehaus.groovy</groupId>
      <artifactId>groovy-all</artifactId>
      <version>2.4.3</version>
    </dependency>
    
    <dependency>
      <groupId>org.spockframework</groupId>
      <artifactId>spock-core</artifactId>
      <version>1.1-groovy-2.4</version>
      <scope>test</scope>
    </dependency>
    
    <dependency>
      <groupId>org.codehaus.groovy.modules.http-builder</groupId>
      <artifactId>http-builder</artifactId>
      <version>0.6</version>
    </dependency>


    <dependency>
      <groupId>org.apache.httpcomponents</groupId>
      <artifactId>httpclient</artifactId>
      <version>4.3.6</version>
    </dependency>


    <dependency>
      <groupId>junit</groupId>
      <artifactId>junit</artifactId>
      <version>3.8.1</version>
      <scope>test</scope>
    </dependency>
  </dependencies>
  
  <build>
        <plugins>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-compiler-plugin</artifactId>
                <version>3.1</version>
                <configuration>
                    <source>1.8</source>
                    <target>1.8</target>
                    <compilerId>groovy-eclipse-compiler</compilerId>
                    <verbose>true</verbose>
                </configuration>
                <dependencies>
                    <dependency>
                        <groupId>org.codehaus.groovy</groupId>
                        <artifactId>groovy-eclipse-compiler</artifactId>
                        <version>2.7.0-01</version>
                    </dependency>
                </dependencies>
            </plugin>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-eclipse-plugin</artifactId>
                <version>2.9</version>
                <configuration>
                    <additionalProjectnatures>
                        <projectnature>org.eclipse.jdt.groovy.core.groovyNature</projectnature>
                    </additionalProjectnatures>
                    <sourceIncludes>
                        <sourceInclude>**/*.groovy</sourceInclude>
                    </sourceIncludes>
                </configuration>
            </plugin>
        </plugins>
    </build>
  
</project>

Eclipse Photon Release (4.8.0)

ставил на нее:

Eclipse Groovy Development Tools 3.0.0.xx-201808011044-e48

Groovy-Eclipse M2E integration 3.0.0.xx-201808011044-e48

Groovy Compiler 2.5 3.0.0.xx-201808011044-e48


  • 0

#2 Spock

Spock

    Специалист

  • Members
  • PipPipPipPipPip
  • 911 сообщений
  • ФИО:Роман

Отправлено 02 Август 2018 - 15:24

может плагинов не хватает, типа gmaven?

https://github.com/s.../master/pom.xml


  • 0

#3 Seys_isv

Seys_isv

    Новый участник

  • Members
  • Pip
  • 3 сообщений
  • ФИО:Иванов Станислав

Отправлено 03 Август 2018 - 08:03

Ага, я вчера их подключил и смог наконец-то запустить тесты. Теперь там другая проблема.

 

в строке

restClient.client.credentialsProvider

Пишет: Cannot resolve symbol 'credentialsProvider'

 

С одной стороны это может быть косяк с подключенными зависимостями, а с другой - намеренно сделана ошибка, чтобы я, как соискатель, ее исправил. Так как при этом все тесты запускаются, то я пока склоняюсь ко 2му варианту. В любом случае, спасибо за помощь. Дальше я сам буду пытаться справляться, самое сложное для меня было - именно запуск проекта. 


  • 0


Программирование на С# для тестировщиков
онлайн, начало 24 августа
Автоматизатор мобильных приложений
онлайн, начало 5 сентября
Selenium WebDriver: полное руководство
онлайн, начало 14 сентября
Программирование на Python для тестировщиков
онлайн, начало 17 августа




Темы с аналогичным тегами eclipse, groovy, spock

Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных

Яндекс.Метрика
Реклама на портале